Not able to import “@angular/material” module

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Asked on November 9, 2020 in php.
Add Comment
5 Answer(s)

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Answered on November 9, 2020.
Add Comment

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Answered on November 9, 2020.
Add Comment

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Answered on November 9, 2020.
Add Comment

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Answered on November 9, 2020.
Add Comment

I’m totally new to mean stack and I’m facing some problems with Angular’s material module. I’m trying to import the “@angular/material” module in my code but I’m getting an error whenever I’m importing it. The error is as follows:

ERROR in src/app/app.module.ts:5:32 - error TS2306: File '/Users/anmolsarraf/Desktop/MEAN Stack/mean-course/node_modules/@angular/material/index .d.ts' is not a module. 

Here is my package.json file:

   {   "name": "mean-course",   "version": "0.0.0",   "scripts": {     "ng": "ng",     "start": "ng serve",     "build": "ng build",     "test": "ng test",     "lint": "ng lint",     "e2e": "ng e2e"   },   "private": true,   "dependencies": {     "@angular/animation": "^4.0.0-beta.8",     "@angular/animations": "~8.2.7",     "@angular/cdk": "^9.0.0",     "@angular/common": "~8.2.7",     "@angular/compiler": "~8.2.7",     "@angular/core": "~8.2.7",     "@angular/forms": "~8.2.7",     "@angular/material": "^9.0.0",     "@angular/platform-browser": "~8.2.7",     "@angular/platform-browser-dynamic": "~8.2.7",     "@angular/router": "~8.2.7",     "rxjs": "~6.4.0",     "tslib": "^1.10.0",     "zone.js": "~0.9.1"   },   "devDependencies": {     "@angular-devkit/build-angular": "~0.803.5",     "@angular/cli": "~8.3.5",     "@angular/compiler-cli": "~8.2.7",     "@angular/language-service": "~8.2.7",     "@types/node": "~8.9.4",     "@types/jasmine": "~3.3.8",     "@types/jasminewd2": "~2.0.3",     "codelyzer": "^5.0.0",     "jasmine-core": "~3.4.0",     "jasmine-spec-reporter": "~4.2.1",     "karma": "~4.1.0",     "karma-chrome-launcher": "~2.2.0",     "karma-coverage-istanbul-reporter": "~2.0.1",     "karma-jasmine": "~2.0.1",     "karma-jasmine-html-reporter": "^1.4.0",     "protractor": "~5.4.0",     "ts-node": "~7.0.0",     "tslint": "~5.15.0",     "typescript": "~3.5.3"   } } 

Any help would be highly appreciated. Thanks!

Professor Answered on November 9, 2020.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.